#138 ✓wontfix
Olav Seyfarth

OpenPGP SmartCard not accessible on Lion with current GPGtools

Reported by Olav Seyfarth | July 27th, 2012 @ 06:23 PM | in 1.8 (closed)

Environment:

OX X version 10.7.4 (up to date)
GPGtools Installer 2012.03.18 (latest release, no updates)

What steps will reproduce the problem? Please be as specific as possible.

Plug in SCR-335 (GnuPG reference card reader)
Insert OpenPGP SmartCard v2 (LED lights up and stays on)
In Terminal, issue command "gpg --card-status"

What do you expect to see? What do you see instead?

Card Status should be shown, card should be accessed.
Instead, I get an error "gpg: OpenPGP card not present: No SmartCard daemon"
 (partly translated back from german locilized output)

Provide any additional information, link a screenshot and debug output if possible.

Debug output from tail -f /var/log/system.log :

(attach card reader to USB) Jul 27 17:30:29 fsd05imac-lan com.apple.kextd[10]: Can't create kext cache under / - owner not root.
Jul 27 17:30:33: --- last message repeated 1 time ---
Jul 27 17:30:33 fsd05imac-lan com.apple.securityd[22]: /SourceCache/SmartcardCCID/SmartcardCCID-55000/ccid/ccid/src/ifdhandler.c:1532:init_driver() Driver version: 1.3.11

(insert card into reader) Jul 27 17:31:24 fsd05imac-lan ReportCrash[26518]: Saved crash report for scdaemon[26517] version ??? (???) to /Users/olav/Library/Logs/DiagnosticReports/scdaemon_2012-07-27-173124_Olavs-iMac.crash
Jul 27 17:31:24 fsd05imac-lan ReportCrash[26518]: Removing excessive log: file://localhost/Users/olav/Library/Logs/DiagnosticReports/scdaemon...

Comments and changes to this ticket

  • Luke Le

    Luke Le July 27th, 2012 @ 09:01 PM

    Hi Olav,

    du kannst auch auf Deutsch posten wenn du magst.

    Kannst du bitte mal dein Terminal öffnen und folgenden Befehl ausführen:

    /usr/local/MacGPG2/bin/scdaemon --server

    und posten was du siehst?

  • Olav Seyfarth

    Olav Seyfarth July 29th, 2012 @ 02:36 PM

    $ /usr/local/MacGPG2/bin/scdaemon --server dyld: lazy symbol binding failed: Symbol not found: _libusb_init
    Referenced from: /usr/local/MacGPG2/lib/libusb-0.1.4.dylib Expected in: flat namespace

    dyld: Symbol not found: _libusb_init
    Referenced from: /usr/local/MacGPG2/lib/libusb-0.1.4.dylib Expected in: flat namespace

    Trace/BPT trap: 5
    $

  • Luke Le

    Luke Le July 29th, 2012 @ 02:37 PM

    Ah ok, dann ist es ein einfacher fix glücklicherweise.

    Einfach die nightly version von MacGPG2 installieren.
    Kannst du von http://nightly.gpgtools.org runterladen.
    Ist dann gpg 2.0.19, haben aber bisher keine Probleme damit gehabt.

  • Olav Seyfarth

    Olav Seyfarth July 29th, 2012 @ 03:39 PM

    Cool, danke, funktioniert mit der nightly.

  • Olav Seyfarth

    Olav Seyfarth July 29th, 2012 @ 03:40 PM

    Bitte Ticket schließen, kann ich nicht bzw. weiß nicht wie.

  • Luke Le

    Luke Le July 29th, 2012 @ 03:40 PM

    • State changed from “new” to “wontfix”

    Sehr gut!

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Shared Ticket Bins

People watching this ticket

Attachments

Pages